Click2Call
Incident Report for MeloTel Network Operations (NOC)
Resolved
Click2Call service has been restored.
Posted Dec 06, 2016 - 16:26 EST
Identified
We are investigating an issue with Click2Call not working. The issue is identified and we will have it resolved very shortly. This issue also causes certificate warning on https://sip.melotel.com
Posted Dec 06, 2016 - 16:23 EST