The performance issue affecting our shared hosting environment has now been resolved. All websites should be loading as expected. We appreciate your patience and understanding during this time.
Posted Oct 29, 2024 - 12:49 EDT
Investigating
We are currently investigating an issue causing high latency in our shared hosting environment, which may result in temporary loading delays for some hosted websites. Our team is addressing this with urgency and will provide updates as soon as possible. Thank you for your patience as we work to resolve this issue.
Posted Oct 29, 2024 - 12:43 EDT
This incident affected: Web & Email Hosting Services (Shared Hosting Services, Email Webmail GUI).