Clcik2Dial Down
Incident Report for MeloTel Network Operations (NOC)
Resolved
Clcik2call service has been restored.
Posted Aug 09, 2022 - 10:21 EDT
Investigating
We are investigating Click2Dial being offline. Updates to follow.
Posted Aug 09, 2022 - 10:17 EDT
This incident affected: VoIP Services (Voip API).