"Processed" Emails Incident Report for SMTP2GO Email Services
Incident Report for MeloTel Network Operations (NOC)
Resolved
SMTP2GO reports: A fix has been implemented.
Posted Oct 13, 2022 - 11:51 EDT
Monitoring
SMTO2GO just Posted: We are currently investigating an issue with emails stuck in "processed" status. Users may experience delivery delays during this time. Although this does not impact traditional email services thru Microsoft365 or GMail. This has an impact on our softwares which are using SMTP2GO for SMTP sending email services.

The incident with SMTP2GO can be followed here: http://smtp2gostatus.com/incidents/3xs1zq67xlrw

We are monitoring the situation closely and will report further updates.
Posted Oct 13, 2022 - 10:02 EDT
This incident affected: Web & Email Hosting Services (Sending Email Services).