Microsoft 365 Service Status (again)
Incident Report for MeloTel Network Operations (NOC)
Resolved
We are happy to report that Microsoft has closed this ticket as resolved.
Posted Jun 08, 2023 - 14:39 EDT
Update
Latest update from Microsoft: After applying mitigations, we're seeing availability return to healthy levels. We're continuing to monitor the environment while we investigate the underlying cause, increase monitoring, and develop further fixes to provide additional relief.
Posted Jun 06, 2023 - 08:50 EDT
Update
Microsoft has pr0ovided an update: We currently do not believe that the previously reverted change is causing the recurrence of impact, though we're working to validate. We're also investigating other factors that may be contributing to the impact. - Updates to follow.
Posted Jun 05, 2023 - 17:09 EDT
Investigating
Microsoft has re-opened the service status ticket from today with the following notes.

We've determined that impact associated with MO571683 and EX571516 is reoccurring. We suspect that impact to our services is similar, though we're investigating to determine the scope of impact and the source of the issue.

Scope of impact: Users routed through the affected infrastructure are affected by this issue, however, impact can vary depending on where users are hosted.

User impact: Users may be unable to access Outlook on the web or other Microsoft 365 services and features.

More info: Impacted services and features may include, but are not limited to:
Exchange Online
- Users are unable to access Outlook on the web

Microsoft Teams
- Users may have difficulties scheduling meetings and/or live events
- Users may have trouble loading people profile cards
- Users may have issues loading file lists
- Users may not be able to create new teams & channels
- Users may not be able to install apps
- Users may have trouble issuing searches
- Users may see delays in admin policy changes taking effect
- Users might see errors when using messaging extensions
- Users may not see up to date Presence information
- Teams Graph APIs may be impacted
- Assignments tab in Teams may not load
- Teams Admin Center functionalities may not perform as expected
Posted Jun 05, 2023 - 16:17 EDT