Click2Call Service Interruption
Incident Report for MeloTel Network Operations (NOC)
Resolved
The Click2Call issue was identified and corrected.
Posted Jan 27, 2020 - 09:53 EST
Monitoring
Click2Call issues have normalized. We are currently monitoring the situation.
Posted Jan 27, 2020 - 09:50 EST
Investigating
We are investigating an Interruption of Click2Call service at this time. This affects both DaFeeder and MeloSIP. Updates to follow shortly.
Posted Jan 27, 2020 - 09:47 EST
This incident affected: Click2Call.