Reports of Caloing Problems
Incident Report for MeloTel Network Operations (NOC)
Resolved
This incident has been resolved.
Posted Dec 04, 2017 - 06:18 EST
Update
Now monitoring. Please send any calling problem reports to support@melotel.com
Posted Dec 01, 2017 - 15:13 EST
Monitoring
ow monitoring. Please send any calling problem reports to support@melotel.com
Posted Dec 01, 2017 - 15:13 EST
Update
We are restarting our core services in an effort to restore services.
Posted Dec 01, 2017 - 15:11 EST
Investigating
We received reports of calling problems. Investigating.
Posted Dec 01, 2017 - 15:08 EST