VoIP Service Issue - Investigation in Progress
Incident Report for MeloTel Network Operations (NOC)
Resolved
No issues identified. Ticket closed.
Posted Oct 16, 2024 - 09:01 EDT
Investigating
We are currently investigating reports of intermittent call issues on our VoIP infrastructure. Our team is actively working to identify the root cause and resolve the problem as quickly as possible. We will keep you updated with further information as it becomes available.
Posted Oct 16, 2024 - 08:55 EDT
This incident affected: VoIP Services (Outgoing Calls).