Service Notice – 611 Technical Support

Incident Report for MeloTel Network Operations (NOC)

Resolved

The routing issue affecting our 611 Technical Support line has now been fully resolved. Calls to 611 are operating normally.

Thank you for your patience and understanding while we worked to correct this matter. If you continue to experience any difficulties, please do not hesitate to contact our support team.
Posted Feb 17, 2026 - 10:34 EST

Identified

We are currently aware of a routing issue affecting calls to our 611 Technical Support line. As a result, some calls may not be connecting properly.

Our team is actively investigating and working to resolve this matter as quickly as possible.

In the meantime, if you require technical assistance, please contact us directly at 416-479-0993 (press option 3) or email support@melotel.com
and our team will be happy to assist you.

We appreciate your patience and will provide an update as soon as this issue has been fully resolved.

— Melo Technology Support Team
Posted Feb 17, 2026 - 09:43 EST