Device Registration Issue Affecting Call Functionality

Incident Report for MeloTel Network Operations (NOC)

Resolved

The trouble with device registration has been resolved.
Posted Oct 20, 2025 - 07:39 EDT

Update

We are currently investigating an issue causing some devices to fail registration, which is preventing affected users from making telephone calls. Our team is working to resolve this as quickly as possible and will provide updates shortly.
Posted Oct 20, 2025 - 07:33 EDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 07:32 EDT

Investigating

We are currently investigating an issue causing some devices to fail registration, which is preventing affected users from making telephone calls. Our team is working to resolve this as quickly as possible and will provide updates shortly.
Posted Oct 20, 2025 - 07:28 EDT
This incident affected: VoIP Services (SIP Registration).