Blocking Caller ID With *67 Results In Failed Call
Incident Report for MeloTel Network Operations (NOC)
Resolved
We’re happy to report that after working with our carriers we were able to solve the problem with sending anonymous caller ID. *67 before your number will now make your call anonymous.
Posted Dec 23, 2019 - 07:59 EST
Identified
We have identified an issue on all calls which are initiating calls with *67 with the intention to block their phone number when placing a call.

Pursuant to CETRP 2018-484, the CRTC has ordered all Canadian Carriers and Telecom Service Providers bound by sections 24 and 24.1 of the Telecommunications Act, to implement network level call blocking (UNCB) as part of the CRTC's efforts to protect Canadians against certain types of unwanted calls by blocking Caller IDs that are "blatantly inaccurate".

The deadline for this implementation is December 18, 2019 and it was implemented by all of our carriers yesterday.

In order to comply with this decision our carriers are blocking all calls terminating on our networks where the transmitted caller ID falls under any of the following criteria:

1. Exceeds 15 digits

2. Malformed by not corresponding to a dial-able number conforming to the North American Numbering Plan such as
a) Unassigned North American Area Codes i.e. 123, 001, or 111 etc.
b) Fewer than 10 digits i.e. 45678
c) No number displayed

We have received several complaints from customers about their ability to make phone calls withholding their Caller ID and we recognize this is an inconvenience.

At the time of the rules being implemented, there was not a clear direction that "no number" would be considered an "invalid number". So we are working with our channel providers to establish official work about this situation.

We are opening this case to keep our customers informed about updates as they become available.
Posted Dec 19, 2019 - 16:28 EST
This incident affected: VoIP Services (Outgoing Calls).