Call Completion Issues

Incident Report for MeloTel Network Operations (NOC)

Resolved

Calls are now completing.
Posted Nov 09, 2025 - 11:44 EST

Investigating

We have become aware of an issue with some incoming and outgoing calls completing. We are investigating and will provide an update shorty.
Posted Nov 09, 2025 - 11:43 EST