Line registration, slow dial and dropped calls
Incident Report for MeloTel Network Operations (NOC)
Resolved
This incident has been resolved.
Posted Oct 25, 2019 - 08:36 EDT
Investigating
We are continuing to investigate an ongoing issue with lines becoming briefly unavailable. Click2call reacting slowly. We apologize for the inconvenience. We are working on identifying the cause of the issue and will update customers shortly.
Posted Oct 24, 2019 - 14:12 EDT
This incident affected: VoIP Services (Outgoing Calls).