Incoming Calls Failing from VoipInnovations, Level3 and Earthlink.
Incident Report for MeloTel Network Operations (NOC)
Resolved
We are happy to report the problem with Level3 has been resolved. An RFO will follow once we have more answers.
Posted Nov 28, 2016 - 11:10 EST
Investigating
We are creating this public ticket to advise you that there appears to be network issues with VoipInnovations, Level 3 and Earthlink affecting internet routing at this time. Details are few, but some customers may experience issues reaching our IP addresses depending on the path you are taking. We will provide additional details as they become available. Callers may be hearing a busy signal or the number is not in service. We are working with our vendors to identify and correct the issue expediently.
Posted Nov 28, 2016 - 09:30 EST