VoIP Server Registration Issues
Incident Report for MeloTel Network Operations (NOC)
Resolved
The services have been restored. If you continue to have any issues, please restart your device to get a new registration.
Posted Mar 06, 2024 - 08:14 EST
Investigating
We are investigating issues with devices registering to the VoIP infrastructure. Updates will follow shortly.
Posted Mar 06, 2024 - 08:08 EST