Microsoft 365 Service Status
Incident Report for MeloTel Network Operations (NOC)
Resolved
Update from Microsoft: Telemetry indicates that service availability is at approximately 99.9% across the service. We're continuing to isolate a small number of components which remain in an unhealthy state and are performing targeted restarts to remediate the residual impact. We will be closing this ticket.
Posted Jun 05, 2023 - 13:18 EDT
Monitoring
Microsoft has provided an update: We've reverted a change which occurred just prior to impact starting and after service replication took place, telemetry is showing significant improvement in availability across the service. Additionally, we've received confirmation from previously impacted users that the issue is no longer occurring. We're continuing to monitor to ensure recovery and are isolating any sections of the service showing residual impact which would require additional recovery actions. - Status changed to Monitoring.
Posted Jun 05, 2023 - 12:32 EDT
Update
Microsoft has provided an update: We've prevented the potentially problematic update from propagating further across the service and are reviewing options to revert the change quickly and safely in those portions of our infrastructure where it has been applied. - Updates will follow as they become available.
Posted Jun 05, 2023 - 12:04 EDT
Identified
Microsoft acknowledged the issue and have provided the following update. "We've identified an update which was applied around the time that impact started. We're reverting the update to potentially mitigate impact whilst we continue to investigate the underlying cause of the issue." Updates to follow.
Posted Jun 05, 2023 - 11:29 EDT
Investigating
At 10:57 AM, Microsoft 365 Status on Twitter posted an update regarding an ongoing investigation into an issue with accessing Outlook on the web. The details can be found under EX571516 in the admin center. However, upon checking the Admin Centre Dashboard, there have been no recent updates. Although there is no official update in the Admin Center, we have received reports from some customers regarding problems authenticating to Outlook online, receiving of emails, viewing old emails and Microsoft Teams. Additionally, MELO Technology is currently facing delays in importing customer support tickets. We are actively monitoring the situation with Microsoft and will provide timely updates as they become available. This issue has been reported globally by other users.
Posted Jun 05, 2023 - 11:27 EDT