SIClytics Call Analytics Platform Problems
Incident Report for MeloTel Network Operations (NOC)
Resolved
MeloTel developed SIClytics in 2015. Since that time, there have been very few updates to the core application. It was considered a cool to have, but it was not seen as critical software at that time.

The core functions of SIClytics were only Call Reporting, Monitor Whisper and calling analytics.

Fast forward to today and we are reporting hundreds of thousands of calls a week across all organizations and the demand is outgrowing the scalability of SIClytics backend development structure.

SIClytics has become an essential tool for all of our customers.

Due to several complex reasons, we have been experiencing challenges with SIClytics and its infrastructure. The symptoms of these issues are the dashboard freezing, click2call not working and some failed reports.

We fully recognize this is a growing problem and something must be done to solve this challenge.

Therefore, we am writing to inform you that we have made the decision to move forward with a complete rebuild of SIClytics platform using the latest technologies.

We have already inked a the approval of this projject and will begin working on the project Scope of work starting from Monday April 11th, 2022, and the workshop to plan the rebuild will be completed over the next 4 weeks.

Once the workshop is completed, we will have the complete scope of the project and can begin development right away.

Redeveloping SIClytics is not a small undertaking and comes a big price. However, we are committed to completing this update and restoring SIClytics to be the best core platform it can be.

We are committed to ensure that SIClytics returns to a much more improved experience, and we are also prepared to continue on improving reporting and calling metrics in future versions.

If you wish to subscribe to further updates to this project. You may subscribe here to be updated: https://emarket.melotel.com//subscription?f=H9fJtf9fdbp7f0C59cWgOU7ptUKReZGZUFTWwagS763KBhPGbaWPM5li9WvQZw9PxF

We appreciate your understanding and support in this change. I ask for your patience.
Posted Apr 08, 2022 - 10:30 EDT
Identified
We are aware of an issue with SIClytics preventing users from accessing the platform. A major bug has been identified which has resulted in the need to rebuild a tool inside the platform. Our dev team is working on a scope of development for this now. Unfortunately, during this time, users can expect to get 502 Bad Gateway messages. While we are working on this today, we kindly ask that you refrain from accessing the dashboard. We apologize for any inconvenience caused.
Posted Apr 01, 2022 - 12:51 EDT
This incident affected: SIClytics (SIClytics Web GUI, Monitor Whisper Panel).