SMTP2GO Service Inturuption
Incident Report for MeloTel Network Operations (NOC)
Resolved
The issue sending email thru smtp2go has been resolved.
Posted Sep 02, 2020 - 10:38 EDT
Identified
We have identified an issue with users subscribing to smtp2go.com to send emails. The error reads: The following SMTP error was encountered: 550 that smtp username's account is not allowed to send. We are investigating this with DMTP2GO now and will provide updates asap.
Posted Sep 02, 2020 - 10:23 EDT
This incident affected: Web & Email Hosting Services (Sending Email Services).