Problems with USA DIDs Call Connectionins
Incident Report for MeloTel Network Operations (NOC)
Resolved
The trouble with incoming calls to our USA DIDs has been resolved.
Posted May 11, 2020 - 17:30 EDT
Update
The issue we're facing affects a limited number of customers, primary utilizing USA DID numbers or hard to get DIDs which reside with VoipInnovations channel services routing to MeloTel. The customers affected are experiencing a complete stoppage in the ability to receive calls. We have confirmed this issue is isolated to the underlying USA Channel provider and we are working with them with urgency to restore the services.
Posted May 11, 2020 - 16:50 EDT
Identified
We have identified an issue with our underlying carrier in the USA resulting in failed calls to our switch to any USA DID. We are working with them on this and hope to have a resolution soon.
Posted May 11, 2020 - 15:44 EDT
This incident affected: VoIP Services (USA DIDs).