Calling problems were identified as being a temporary issue which affecting multiple carriers across Canada. The issue has been reported to be resolved, and we are unable to replicate any problems at this time. We apologize for any inconvenience if you continue to experience any problems, please report them to technical support.
Posted Nov 20, 2024 - 09:53 EST
Investigating
We are currently investigating issues with our primary provider that have resulted in some failed or poor-quality calls. To minimize the impact, we have temporarily adjusted call routing and are actively working with the vendor to resolve the problem. We will share updates as soon as possible. Thank you for your patience.
Posted Nov 20, 2024 - 08:55 EST
This incident affected: VoIP Services (Outgoing Calls).