Intermittant Toll-Free DID Connectivity Issues
Incident Report for MeloTel Network Operations (NOC)
Resolved
Our underlying carrier did not find any CDR details from the Calling party in our side. The calls are not hitting their gateway.

They are in the process of opening a ticket with the primary upstream carrier but for faster resolution please advise the calling party number to open a ticket with his Service provider.

We would like to note as well that while our capacity levels are not full, many ILEC land and wireless networks are saturated due to the current situation with COVID-19.
Posted Mar 23, 2020 - 16:04 EDT
Update
Unfortunately we are not getting very clear answers regarding the issues with incoming calls to our toll free numbers. However, we have noticed that the majority of calls are now coming thru. Although there does appear to b a delay on the call connecting. Updates will follow as they become available.
Posted Mar 23, 2020 - 14:37 EDT
Update
We are still investigating the issue... However Bell, Rogers and Telus all acknowledged their networks are experiencing higher-than-normal traffic. And the telecommunications giants pledge their infrastructure can handle the sudden surge.

Telus said in an email that it has an "unprecedented volume of mass-calling events." such as conference bridges etc.

In some firms, employees shared anecdotes of teleconferences breaking down entirely under the strain of added usage.

Telecom providers said they were working together to ensure connection between networks would be more resilient.

The three main service providers said they're all increasing their ability to deal with the traffic as usage grows.

I am hoping to followup with any any positive news as it becomes available.
Posted Mar 23, 2020 - 12:33 EDT
Investigating
We are currently investigating problems with Toll-Free DID routing issues. Many customers have reported they are intermittently unable to get calls into their Toll-Free DIDs. This issue is not related to any deficiency on MeloTel service. We have opened a ticket with the underlying carrier, however we believe this may be related to capacity issues due to many home workers across the country at this time. We will followup with any details we get during as soon as they become available. The issue appears related to Toll Free DIDs only at this time.
Posted Mar 23, 2020 - 12:21 EDT
This incident affected: VoIP Services (Toll Free DIDs).