MeloTel Customer Portal Maintenance
Incident Report for MeloTel Network Operations (NOC)
Resolved
Maintenance completed. Access has been restored.
Posted 6 months ago. Apr 01, 2019 - 14:33 EDT
Identified
MeloTel Customer Portal is currently in Maintenance mode while we perform updates. This prevents access to customer profiles temporarily. We apologize for the inconvenience. This does not affect any other MeloTel services.
Posted 6 months ago. Apr 01, 2019 - 12:39 EDT
This incident affected: MeloTel Core Systems (MeloTel Customer Portal).