SSL Certificate issue with sites and services hosted by our shared hosting CPanel
Incident Report for MeloTel Network Operations (NOC)
Resolved
SSL certificate issue on our shared CPanel environment has been resolved. If you continue to have issues, please restart your device and try again. Call support if you have any ongoing issues.
Posted Dec 09, 2021 - 23:14 EST
Investigating
We are investigating an issue with our sites hosted in our Shared CPanel hosting prompting an insecure SSL certifcate notice for IMAP and Website visitors. We are working on this and hope to have a resolution shortly.
Posted Dec 09, 2021 - 13:01 EST
This incident affected: Web & Email Hosting Services (Shared Hosting Services).